蚂蚱也是肉
点滴汇聚,终成大海

[RouterOS] 屏蔽各大视频网站播放前15秒30秒广告【3.11 屏蔽优酷大屏广告】

解决优酷反屏蔽机制脚本

/ip firewall filter

add action=add-dst-to-address-list address-list=yk-1 address-list-timeout=5s \

chain=forward comment=”\D3\C5\BF\E1\B9\E3\B8\E6″ content=\

“{\”RS\”:\”http://f.youku.com/player/getFlvPath/fileid/” disabled=no \

dst-address-list=!yk-2 protocol=tcp src-port=80

add action=add-dst-to-address-list address-list=yk-2 address-list-timeout=1d \

chain=forward comment=”” content=\

“{\”RS\”:\”http://f.youku.com/player/getFlvPath/fileid/” disabled=no \

dst-address-list=yk-1 protocol=tcp src-port=80

add action=drop chain=forward comment=”” content=\

“{\”RS\”:\”http://f.youku.com/player/getFlvPath/fileid/” disabled=no \

dst-address-list=!yk-1 protocol=tcp src-port=80

add action=drop chain=forward comment=”” content=\

“S\”:\”http://static.atm.youku.com/” disabled=no protocol=tcp src-port=80

 

默认脚本

 

/ip firewall filter

add action=drop chain=forward comment=”\CC\DA\D1\B6\CA\D3\C6\B5\B9\E3\B8\E6 \

\B9\E6\D4\F2\CE\CA\CC\E2\B7\B4\C0\A1QQ\A3\BA59473472″ content=\

“Host: adslvfile.qq.com” disabled=no dst-port=80 protocol=tcp

add action=drop chain=forward comment=”\D1\B8\C0\D7\BF\B4\BF\B4\B9\E3\B8\E6″ \

content=http://float.sandai.net/finalfiles/ disabled=no protocol=tcp \

src-port=80

add action=jump chain=forward comment=”\C6\E6\D2\D5\B9\E3\B8\E6″ content=\

“Host: policy.cupid.qiyi.com” disabled=no dst-port=80 jump-target=qiyi \

protocol=tcp

add action=drop chain=qiyi comment=”” content=”GET /adpolicy” disabled=no

add action=jump chain=forward comment=”PPS\B9\E3\B8\E6″ content=\

“Host: notice.ppstream.com” disabled=no dst-port=80 jump-target=pps \

protocol=tcp

add action=drop chain=pps comment=”” content=.swf disabled=no

add action=drop chain=pps comment=”” content=.flv disabled=no

add action=drop chain=forward comment=”PPTV\B9\E3\B8\E6″ content=\

“Host: iafp.pptv.com” disabled=no dst-port=80 protocol=tcp

add action=jump chain=forward comment=”\CB\D1\BA\FC\B9\E3\B8\E6″ content=\

“Host: images.sohu.com” disabled=no dst-port=80 jump-target=so protocol=\

tcp

add action=jump chain=forward comment=”” content=”Host: mfiles.sohu.com” \

disabled=no dst-port=80 jump-target=sohu protocol=tcp

add action=jump chain=so comment=”” content=Main.swf disabled=no jump-target=\

sohu

add action=drop chain=sohu comment=”” content=.mp4 disabled=no

add action=drop chain=sohu comment=”” content=.swf disabled=no

add action=jump chain=forward comment=”\CD\C1\B6\B9\B9\E3\B8\E6″ content=\

“Host: v2.tudou.com” disabled=no dst-port=80 jump-target=tudou protocol=\

tcp

add action=drop chain=tudou comment=”” content=/tdcm/adcontrol disabled=no

add action=jump chain=forward comment=”56\CD\F8″ content=cdn.56imgs.com:88 \

disabled=no dst-port=88 jump-target=56 protocol=tcp

add action=drop chain=56 comment=”” content=/flashApp/player_res/module/ad/ \

disabled=no

add action=jump chain=forward comment=”\C0\D6\CA\D3\CD\F8″ content=letv.com \

disabled=no jump-target=le protocol=tcp src-port=80

add action=drop chain=le comment=”” content=<address>http:// disabled=no

add action=drop chain=forward comment=”\D3\C5\BF\E1\B9\E3\B8\E6″ content=\

“{\”RS\”:\”http://f.youku.com/player/getFlvPath/fileid/” disabled=no \

protocol=tcp src-port=80

add action=drop chain=forward comment=”” content=\

“S\”:\”http://static.atm.youku.com/” disabled=no protocol=tcp src-port=80

add action=drop chain=forward comment=”\BF\E16\B9\E3\B8\E6″ content=\

“Host: aagw.sdo.com” disabled=no dst-port=80 protocol=tcp

add action=drop chain=forward comment=”” content=\

“\”sad\”:\”http://main.gslb.ku6.com/” disabled=no protocol=tcp src-port=\

80

add action=drop chain=forward comment=”\D0\C2\C0\CB” content=\

“<ref><![CDATA[http://d1.sina.com.cn/” disabled=no protocol=tcp src-port=\

80

add action=drop chain=forward comment=”\BC\A4\B6\AF\CD\F8\B9\E3\B8\E6″ \

content=”<![CDATA[http://86mms.megajoy.com/uploadfiles/” disabled=no \

protocol=tcp src-port=80

2012-06-03
4,282 views

发表回复